Not getting any app updates

It seems that there were at least two public (i.e. non-beta) updates to SeriesGuide over the last few months. I haven’t seen any of them: the app says I’m using v57 (Database v48), there are no updates available to it in Google Play, and “What’s new” section there says that the app was last updated Dec 4, 2020.

I’m using Samsung Galaxy S7 with Android 8.0.0 (the latest available to my device).

I’m not getting the updates too. The app still says v57 (Database v48) and in Google Play says that the app was last updated Dec 4, 2020.

I’m using Samsung Galaxy S10e with Android 11 and I’m from Brazil.

I want to know if there’s any idea when the updates will arrive on the play store. Thank you.

58.2 is last version

Same here: I’m running v57, and have not received any notification of an update on my phone. If I look it up on my PC, the Play Store shows it was updated on 1 May, however I can not see this update on my phone. On my phone, the Play Store still shows v57, updated on 4 Dec 2020.

If you surf to :

Do you have the option there to install or update the show on your device?

For myself, I can see it it installed on both my devices, no option to update, but my version is up-to-date so this is correct.

Tried this on my pc with an app that wasn’t up-to-date, clicked on install, and it immediately started updating on my tablet.

It says “Your device already has this item installed.” No option to update.

Left are from web, right is from the phone

Same thing here. There’s no option to update

Weird. Let’s hope Uwe knows what’s going wrong.

If you know how to install an apk, you can find the latest version here :

If you’ve never heard about apk, just wait for Uwe.

The Google Play store on the web shows the app updated on May 1st. And on the phone was last updated Dec 4, 2020.

I’ve tried to uninstall the app, and once the app was off my phone I installed again via the web and still hasn’t changed anything. The app still running the v57 (Database v48).

I’m using the Samsung Galaxy S10e with Android 11, and my phone has the Android updated with the latest version available, the app store is updated as well.

I really don’t know what’s happening. The version 58 was released on April 16th, version 58.1 on April 21st and version 58.2 on May 1st and I haven’t received any of them!

I hope Uwe can answer what’s going on…

SeriesGuide 57 is the currently available version if you are not in the beta program.

SeriesGuide 58 (58.2 currently) is being rolled out slowly since a few days (slower than usual), it may take a few more days/weeks until your device will get it.

Thanks for the clarification.

Guess I was mislead by this tweet:

Thanks, I didn’t realise that a released version isn’t just released to everyone at the same time. I assumed it was something to do with device compatibility.