Subscription not working

I just started using SeriesGuide, and bought the All Access Sub. Unfortunately, even though Google shows the subscription active, the Android app shows the following error when trying to unlock features:

The subscription is currently not available (acknowledgeNonConsumablePurchasesAsync failed. 5: )

I tried clearing cache and data, and even completely uninstalled then re-installed the app, but still can’t get it to work. I’m running Android 7.1.1.


Hello! This error indicates that the app could not acknowledge your purchase with Google Play. Did you install the app through Google Play?

Anyhow: if you email me at uwe AT (and include the email address of your Google account or the order number) I can have a look at the actual purchase to see any issues.

Yes, I installed it through Google Play. Interestingly, Google cancelled my subscription. They didn’t give a reason why, but I assume it was because they detected there was a problem. In any case, I tried subscribing again, and got the same error.

I will email you with the details. Thanks.

I’ve got the same problem. “Your subscription has expired” every time I use the app. No, it has not.

@Sascha_Schneider Thanks for sharing! Could you also email me your Google account email address to uwe AT Also knowing your device model and version of Android might help me find this in the automated error reports.