Ignore special episodes?

I can’t seem to find this option any more. On my tablet, special episodes are hidden but they show on my phone.

Welcome! It should be in More > Settings > Advanced.

I have no idea why I looked 10 times in there be couldn’t see that Advanced was clickable!
Thank you